We're having technical issues ⚠️

Incident Report for Cuvva

Resolved

This incident has been resolved.
Posted Aug 25, 2022 - 17:50 BST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2022 - 13:56 BST

Update

We are continuing to investigate this issue.
Posted Aug 25, 2022 - 13:44 BST

Investigating

We are currently investigating this issue.
Posted Aug 25, 2022 - 13:16 BST
This incident affected: 📱 Cuvva App.