⚠️ Some payments might fail
Incident Report for Cuvva
Resolved
Everything is running smoothly again 🎉
Posted Jul 10, 2019 - 18:30 BST
Monitoring
Stripe has fixed the problem, and we're monitoring to make sure everything is okay.
Posted Jul 10, 2019 - 18:17 BST
Investigating
Our payment processor is experiencing issues, meaning you might have problems purchasing policies. We're investigating 🕵️‍♀️
Posted Jul 10, 2019 - 17:49 BST
This incident affected: 💳 Card Payments.