We're seeing issues with the app ⚠️
Incident Report for Cuvva
Resolved
We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.
Posted Aug 15, 2022 - 09:45 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 14, 2022 - 17:37 BST
Update
We are continuing to investigate this issue.
Posted Aug 14, 2022 - 16:41 BST
Investigating
We're seeing some issues with one of our systems so you may not be able to get a quote or pay for your subscription. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Aug 14, 2022 - 16:12 BST
This incident affected: 📱 Cuvva App and 💳 Card Payments.