We're seeing issues with the app 🚫
Incident Report for Cuvva
Resolved
Good news! It looks like everything is back to normal! πŸŽ‰

We’re sorry for any hassle this might have caused. 😊
Posted Apr 06, 2021 - 17:43 BST
Monitoring
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Apr 06, 2021 - 17:34 BST
Investigating
We're seeing some issues with one of our systems so you may not be able to get a quote. 😞

Our engineers are looking into this, and should have it fixed soon πŸ› οΈ
Posted Apr 06, 2021 - 17:24 BST
This incident affected: πŸ“± Cuvva App.