Book Ahead Policies
Resolved·Partial outage

This incident has been resolved.

Thu, May 30, 2024, 03:59 PM
(1 year ago)
·
Affected components
📱 Cuvva App
Updates

Resolved

This incident has been resolved.

Thu, May 30, 2024, 03:59 PM

Investigating

We are currently investigating a technical issue 🛠️ with booking, book ahead policies.

Thu, May 30, 2024, 03:08 PM(50 minutes earlier)