πŸŒ† Low visibility from orange sky, drive safe!
Resolved

This incident has been resolved.

Mon, Oct 16, 2017, 05:46β€―PM
(7 years ago)
Β·
Affected components

No components marked as affected

Updates

Resolved

This incident has been resolved.

Mon, Oct 16, 2017, 05:46β€―PM

Monitoring

Sand from the Sahara is making the sky over the UK very dark and orange...

Mon, Oct 16, 2017, 02:32β€―PM(3 hours earlier)