⚠️ Driving licence lookups failing
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Oct 20, 2017 - 13:51 BST
Monitoring
The DVLA are back up, we will continue to monitor the situation in the meantime 🕵️
Posted Oct 20, 2017 - 12:55 BST
Identified
The DVLA licence system is down, some licence lookups will fail due to this. We will post updates as we get more information 😥
Posted Oct 20, 2017 - 10:13 BST