We're seeing issues with the app ⚠️
Incident Report for Cuvva
Resolved
We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.
Posted Mar 06, 2022 - 12:30 GMT
Update
We are continuing to investigate this issue.
Posted Mar 06, 2022 - 12:22 GMT
Investigating
We're seeing some issues with one of our systems so you may not be able to get a quote. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Mar 06, 2022 - 11:43 GMT
This incident affected: 📱 Cuvva App.