In-app support might be slower ⚠️
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Dec 04, 2022 - 09:36 GMT
Identified
Intercom have identified the issue, and they're investigating. We'll update once we know more 👍
Posted Dec 04, 2022 - 08:46 GMT
This incident affected: 💬 In-app customer support.