⚠️ Driving licence lookups might fail
Incident Report for Cuvva
Resolved
Licence lookups are working again 🎉
Posted Mar 28, 2020 - 21:55 GMT
Investigating
We are experiencing issues with the DVLA licence system, so some licence lookups will fail due to this. We will post updates as we get more information 😥
Posted Mar 28, 2020 - 11:51 GMT
This incident affected: 🎫 Driving licence checks.