Some payments might fail ⚠️
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Jan 26, 2023 - 16:15 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 26, 2023 - 16:15 GMT
Investigating
We’re seeing some issues with payments and understand this is affecting some customers. Our engineers are currently investigating this issue.
Posted Jan 26, 2023 - 13:03 GMT
This incident affected: 💳 Card Payments.