❄️ Met Office: yellow weather warning
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Jan 30, 2019 - 12:01 GMT
Monitoring
There is a yellow weather warning for snow and ice. Please take care when driving. Pricing is slightly higher due to the increased risk.
Posted Jan 29, 2019 - 17:07 GMT
This incident affected: ⚠️ Driving safety.