System maintenance 🚧
CompleteΒ·Under maintenance

Correcting.

Thu, Mar 12, 2020, 06:00β€―PM
(5 years ago)
Β·
Affected components
πŸ“± Cuvva App
πŸš— Vehicle lookups
🎫 Driving licence checks
πŸ’³ Card Payments
Updates

Complete

Correcting.

Thu, Mar 12, 2020, 06:00β€―PM

In progress

Our systems are down for maintenance, but should be back up and running soon πŸ› 

Thu, Mar 12, 2020, 04:48β€―PM(1 hour earlier)

In progress

Scheduled maintenance is currently in progress. We will provide updates as necessary.

Thu, Mar 12, 2020, 01:00β€―PM(3 hours earlier)

Scheduled

We're updating some things behind the scenes, so there will be a time where the app won't work.

This shouldn't be long, we're expecting it to be around 5 minutes πŸŽ‰

We'll keep you updated if things don't go to plan!

Thu, Mar 12, 2020, 12:06β€―PM(53 minutes earlier)