Some payments might fail ⚠️
Incident Report for Cuvva
Resolved
It looks like everything is working again 🎉

We’re very sorry for any hassle caused today.
Posted Mar 22, 2023 - 16:34 GMT
Monitoring
Stripe has resolved the problem and you can try to purchase a policy again.

We’ll be monitoring this, to ensure everything is okay 👍
Posted Mar 22, 2023 - 16:27 GMT
Investigating
We’re seeing some issues with our third party payment system, Stripe. We understand this is affecting customers buying policies.

This isn't something we can control directly but we're waiting on Stripe to find out more.👂
Posted Mar 22, 2023 - 16:03 GMT
This incident affected: 💳 Card Payments.