Payments are back up and running ✅
Resolved·Full outage

Payments are back up and running ✅

Wed, Mar 10, 2021, 12:19 PM
(4 years ago)
·
Affected components
💳 Card Payments
Updates

Resolved

Payments are back up and running ✅

Wed, Mar 10, 2021, 12:19 PM

Monitoring

We are continuing to monitor for any further issues.

Wed, Mar 10, 2021, 12:19 PM

Monitoring

Our engineers have resolved the problem and you can try to purchase a policy again.

We’ll be monitoring this, to ensure everything is okay 👍

Wed, Mar 10, 2021, 12:12 PM

Investigating

We’re experiencing some issues with our payment system. We understand this is affecting customers buying policies.

We're investigating now and we'll let you know once we've identified the problem 🔍

Wed, Mar 10, 2021, 12:06 PM