We're seeing issues with the app ⚠️
Incident Report for Cuvva
Resolved
We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.
Posted Jun 15, 2021 - 15:32 BST
Investigating
We're seeing some issues with one of our systems so you may not be able to get a quote on certain vehicles. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Jun 15, 2021 - 13:32 BST
This incident affected: 📱 Cuvva App.