Some payments might fail ⚠️
Resolved·Partial outage

This incident has been resolved.

Tue, Jul 20, 2021, 09:47 AM
(3 years ago)
·
Affected components
📱 Cuvva App
💳 Card Payments
Updates

Resolved

This incident has been resolved.

Tue, Jul 20, 2021, 09:47 AM

Monitoring

Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊

Tue, Jul 20, 2021, 09:46 AM

Identified

Our engineers have identified the issue, and are working on a fix for the issue.

Once we know more, we'll keep you updated 👍

Tue, Jul 20, 2021, 09:42 AM

Investigating

We’re seeing some issues with our payments system. We understand this is affecting customers buying policies.

We're looking into this and we'll update as soon as we have more information.👂

Tue, Jul 20, 2021, 09:38 AM