Customer support temporarily unavailable
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Nov 03, 2017 - 10:38 GMT
Identified
Our in-app support system is having intermittent issues. Emailing support@cuvva.com still works!
Posted Nov 03, 2017 - 10:17 GMT