We're seeing issues with the app ⚠️
Resolved·Degraded performance

This incident has been resolved.

Thu, May 20, 2021, 12:38 PM
(4 years ago)
·
Affected components
📱 Cuvva App
Updates

Resolved

This incident has been resolved.

Thu, May 20, 2021, 12:38 PM

Investigating

We're seeing some issues with one of our systems so you may not be able to upload a photo or documents into the app. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️

Thu, May 20, 2021, 12:10 PM(27 minutes earlier)