Some payments might fail ⚠️
Incident Report for Cuvva
Resolved
We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.
Posted Oct 07, 2021 - 17:20 BST
Update
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Oct 07, 2021 - 15:34 BST
Update
We're seeing some issues with one of our systems so you may not be able to get a quote. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Oct 07, 2021 - 15:04 BST
Investigating
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Oct 07, 2021 - 14:53 BST
Identified
Our payments processor, Stripe has identified the issue that is causing some payment attempts to fail 💳.

They’re working to resolve this as quickly as possible. In the meantime we'll keep you updated of any changes.
Posted Oct 07, 2021 - 14:47 BST
Investigating
We’re seeing some issues with our third party payment system, Stripe. We understand this is affecting customers buying policies.

This isn't something we can control directly but we're waiting on Stripe to find out more.👂
Posted Oct 07, 2021 - 14:41 BST
This incident affected: 📱 Cuvva App and 💳 Card Payments.