We're seeing issues with the app ⚠️
Incident Report for Cuvva
Resolved
We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.
Posted Aug 03, 2023 - 19:01 BST
Update
We are continuing to investigate this issue.
Posted Aug 03, 2023 - 19:00 BST
Update
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Aug 03, 2023 - 18:46 BST
Investigating
We're seeing some issues with one of our systems so you may not be able to get a quote. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Aug 03, 2023 - 17:52 BST
This incident affected: 📱 Cuvva App.