Some payments might fail ⚠️
Resolved·Partial outage

This incident has been resolved.

Thu, Jul 13, 2023, 11:45 AM
(1 year ago)
·
Affected components
💳 Card Payments
Updates

Resolved

This incident has been resolved.

Thu, Jul 13, 2023, 11:45 AM

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Jul 13, 2023, 09:37 AM(2 hours earlier)

Identified

Our payments processor, Stripe has identified the issue that is causing some payment attempts to fail 💳.

They’re working to resolve this as quickly as possible. In the meantime we'll keep you updated of any changes.

Thu, Jul 13, 2023, 09:02 AM(35 minutes earlier)