We're seeing issues with the app ⚠️
Resolved·Full outage

This incident has been resolved.

Thu, Apr 27, 2023, 03:24 PM
(2 years ago)
·
Affected components
📱 Cuvva App
Updates

Resolved

This incident has been resolved.

Thu, Apr 27, 2023, 03:24 PM

Identified

Our engineers have identified the issue, and are working on a fix for the issue.

Once we know more, we'll keep you updated 👍

Thu, Apr 27, 2023, 02:57 PM(26 minutes earlier)