We're seeing issues with the app ⚠️
Incident Report for Cuvva
Resolved
We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.
Posted Sep 26, 2022 - 13:12 BST
Monitoring
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Sep 26, 2022 - 12:59 BST
Identified
Our engineers have identified the issue, and are working on a fix for the issue.

Once we know more, we'll keep you updated 👍
Posted Sep 26, 2022 - 12:59 BST
This incident affected: 📱 Cuvva App.