We're seeing issues with the app ⚠️.
Resolved·Partial outage

This incident has been resolved.

Mon, Apr 3, 2023, 04:15 PM
(2 years ago)
·
Affected components
📱 Cuvva App
Updates

Resolved

This incident has been resolved.

Mon, Apr 3, 2023, 04:15 PM

Identified

The issue has been identified and a fix is being implemented.

Mon, Apr 3, 2023, 04:11 PM

Investigating

We are currently investigating this issue.

Mon, Apr 3, 2023, 03:57 PM(14 minutes earlier)