⚠️ Adding new payment methods is failing
Resolved·Partial outage

This incident has been resolved.

Wed, Dec 19, 2018, 03:11 PM
(6 years ago)
·
Affected components
💳 Card Payments
Updates

Resolved

This incident has been resolved.

Wed, Dec 19, 2018, 03:11 PM

Monitoring

Due to an external outage, you might experience issues when trying to add payment cards to your account. We're monitoring the issue and will post an update when we know more

Wed, Dec 19, 2018, 02:25 PM(46 minutes earlier)