We're seeing issues with the app ⚠️
Resolved·Partial outage

We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.

Thu, Jul 13, 2023, 06:00 PM
(1 year ago)
·
Affected components
📱 Cuvva App
Updates

Resolved

We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.

Thu, Jul 13, 2023, 06:00 PM

Monitoring

A fix has been implemented and we are monitoring the results.

Thu, Jul 13, 2023, 05:25 PM(35 minutes earlier)

Investigating

We're seeing some issues with one of our systems so you may not be able to get a quote. 😞

Our engineers are still looking into this, and should have it fixed soon 🛠️

Thu, Jul 13, 2023, 04:57 PM(27 minutes earlier)

Investigating

We're seeing some issues with one of our systems so you may not be able to get a quote. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️

Thu, Jul 13, 2023, 04:26 PM(30 minutes earlier)