You won't be able to quote right now ⚠️
Incident Report for Cuvva
Resolved
Thanks for hanging in there while we sorted the issue, everything should be back to normal now 🎉
Posted Mar 31, 2020 - 18:29 BST
Monitoring
We found the issue and it should be fixed, sorry for any hassle! 💪
Posted Mar 31, 2020 - 18:24 BST
Investigating
We're seeing some issues with one of our systems so we're not able to give quotes. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Mar 31, 2020 - 18:22 BST
This incident affected: 📱 Cuvva App.