⚠️ We're seeing issues with the app
Incident Report for Cuvva
Resolved
Everything is running smoothly again now👌

Sorry for any hassle it might have caused!
Posted Jun 09, 2020 - 11:38 BST
Monitoring
Our engineers have found the problem and it should be fixed, but we're keeping an eye to make sure everything is okay 🔥
Posted Jun 09, 2020 - 11:10 BST
Investigating
We're seeing some issues in the app, so you won't be able to get a quote or purchase. But our engineers are taking a look, so hopefully it should be fixed soon 🛠️
Posted Jun 09, 2020 - 11:04 BST
This incident affected: 📱 Cuvva App.