Driving licence lookups failing
Incident Report for Cuvva
Postmortem

Looking forward, to prevent occurrences like this in the future, we are doing work to reduce our reliance on the availability of MyLicence.

Unfortunately, as the only provider of DVLA data in the world, there is no secondary provider we can add to ensure redundancy, as we would with any other external service provider. As such, we cannot operate entirely without MyLicence.

However, we are going to adjust our data collection processes slightly to enable us to make use of the driving licence data we already hold. i.e. if you have received a quote in the last 24 hours, or have ever purchased a Cuvva policy before, we can re-use the existing data we hold. After the 24-hour mark, we are unfortunately required to delete the licence data if you haven't purchased a policy in that time.

There was also another surprising learning experience from this incident. Although we were aware of the MyLicence downtime within about a minute, it turned out that the MyLicence team actually were not aware of the downtime. I (James, CTO) emailed them asking for an update early this morning; they promptly responded explaining that they were not aware of any incidents. Within about 5 minutes of informing them, the issue was resolved. Although it seems quite odd that they didn't know until that point, in the future we will make sure to contact them immediately.

We are now going through the process of identifying and contacting all affected customers. We apologise for this inconvenience, particularly to our subscription customers, who we recognise rely on us entirely in order to use their cars.

Posted Sep 26, 2017 - 10:37 BST

Resolved
This incident has been resolved.
Posted Sep 26, 2017 - 10:29 BST
Monitoring
The MyLicence system is back online. Quoting and purchasing are working again, as normal.
Posted Sep 26, 2017 - 09:07 BST
Identified
The DVLA driving licence service (MyLicence) is currently down, which means we can't quote. 😣
Posted Sep 25, 2017 - 20:24 BST