❄️ Met Office: amber weather warning
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Feb 01, 2019 - 13:00 GMT
Monitoring
There is a amber weather warning for snow and ice. Please take care when driving. Pricing is slightly higher due to the increased risk.
Posted Jan 31, 2019 - 17:11 GMT
This incident affected: ⚠️ Driving safety.