We've got scheduled maintence coming soon 🛠️
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Sep 13, 2022 - 11:52 BST
Investigating
Some essential maintenance has been scheduled for 10AM-10:30AM on Tuesday 13th September 2022.

During this time, you might not be able to reach our customer support team.

We will provide updates as necessary 💬
Posted Sep 12, 2022 - 18:20 BST
This incident affected: 💬 In-app customer support.