In-app support is down ⚠️
Incident Report for Cuvva
Resolved
It looks like we're back, sorry for any hassle there! 🎉
Posted Apr 21, 2020 - 17:36 BST
Investigating
We're seeing issues with Intercom (our in-app chat) and we're looking into it.

While we're waiting on Intercom to find out more, you might not be able to contact us. 😞
Posted Apr 21, 2020 - 17:29 BST
This incident affected: 💬 In-app customer support.