Card payments might not work ⚠️
Incident Report for Cuvva
Resolved
Payments are working now, so you should be good to go 💸

We’re sorry for any hassle!
Posted Dec 21, 2019 - 22:00 GMT
Update
Payments should be working, but we're keeping an eye on things 🔍
Posted Dec 21, 2019 - 21:19 GMT
Monitoring
Engineers have found the problem, and they're looking at it. But you should be able to purchase now 💸
Posted Dec 21, 2019 - 21:09 GMT
Identified
We've got engineers taking a look 🛠

​As soon as we know more, we'll let you know!
Posted Dec 21, 2019 - 20:54 GMT
Investigating
We're having some payments with the app at the moment, and we're looking into it! 🛠
Posted Dec 21, 2019 - 20:50 GMT
This incident affected: 💳 Card Payments.