Driving licence lookups might fail ⚠️
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Jan 26, 2020 - 09:24 GMT
Update
We're still seeing issues, but we're keeping an eye on things 👀
Posted Jan 25, 2020 - 14:24 GMT
Update
It looks like we're still seeing intermittent issues with the DVLA licence system, so some customers won't be able to add their licence or get quotes.

We're still monitoring the situation, but if you do need insurance in the meantime please look for cover elsewhere 🛠
Posted Jan 25, 2020 - 13:36 GMT
Monitoring
It looks like DVLA have fixed the issue, but we're monitoring to make sure it's okay 🛠
Posted Jan 25, 2020 - 10:52 GMT
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 25, 2020 - 09:21 GMT
Investigating
We’re currently seeing issues with the DVLA licence system, so some customers won’t be able to add their licence or get a quote. ❌

We’d recommend trying again later today. If you urgently need insurance you may need to look elsewhere. We’re really sorry for any hassle 😞
Posted Jan 25, 2020 - 09:14 GMT
This incident affected: 🎫 Driving licence checks.