In-app support is down
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted May 07, 2024 - 18:10 BST
Update
We are continuing to investigate this issue.
Posted May 07, 2024 - 17:32 BST
Update
We are continuing to investigate this issue.
Posted May 07, 2024 - 17:02 BST
Update
We are continuing to investigate this issue.
Posted May 07, 2024 - 16:56 BST
Investigating
We're currently experiencing issues with Intercom our chat provider, and we're looking into it.

This isn't something we can control directly but we're waiting on Intercom to find out more. 👂
Posted May 07, 2024 - 16:24 BST
This incident affected: 💬 In-app customer support.