In-app support is down

Incident Report for Cuvva

Resolved

It looks like we're all sorted.

Sorry for any hassle with this!
Posted May 29, 2024 - 17:29 BST

Identified

Intercom have identified the issue, and they're investigating. We'll update once we know more 👍
Posted May 29, 2024 - 16:25 BST

Investigating

We're currently experiencing issues with Intercom our chat provider, and we're looking into it.

This isn't something we can control directly but we're waiting on Intercom to find out more. 👂
Posted May 29, 2024 - 16:13 BST
This incident affected: 💬 In-app customer support.