We're seeing issues with the app ⚠️
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Jun 25, 2020 - 18:48 BST
Monitoring
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Jun 25, 2020 - 17:46 BST
Identified
Our engineers have identified the issue, and are investigating the problem.

Once we know more, we'll keep you updated 👍
Posted Jun 25, 2020 - 17:16 BST
Investigating
We're seeing some issues with one of our systems so we're not able to give quotes. 😞

Our engineers are looking into this, and should have it fixed soon 🛠️
Posted Jun 25, 2020 - 17:01 BST
This incident affected: 📱 Cuvva App.