Customer support temporarily unavailable
Resolved·Full outage

This incident has been resolved.

Thu, Mar 21, 2019, 11:14 AM
(6 years ago)
·
Affected components
💬 In-app customer support
Updates

Resolved

This incident has been resolved.

Thu, Mar 21, 2019, 11:14 AM

Identified

Our third party in-app support system is having issues right now so you may not be able to contact us 😔

Thu, Mar 21, 2019, 10:55 AM(18 minutes earlier)