We're seeing issues with one of our systems
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 09:40 BST
Investigating
Our support team may not be able to help with a few things due to an issue with one of our systems.

Our engineers are looking into this and should have it fixed soon 🛠️
Posted Apr 16, 2024 - 09:36 BST
This incident affected: 💬 In-app customer support.