⚠️ Some payments might fail
ResolvedΒ·Partial outage

Everything is running smoothly again πŸŽ‰

Wed, Jul 10, 2019, 11:43β€―PM
(6 years ago)
Β·
Affected components
πŸ’³ Card Payments
Updates

Resolved

Everything is running smoothly again πŸŽ‰

Wed, Jul 10, 2019, 11:43β€―PM

Monitoring

Stripe has fixed the problem, and we're monitoring to make sure everything is okay.

Wed, Jul 10, 2019, 11:00β€―PM(43 minutes earlier)

Identified

Stripe is currently experiencing issues, meaning you might have problems purchasing policies. We're investigating.. again πŸ•΅οΈβ€β™€οΈ

Wed, Jul 10, 2019, 09:46β€―PM(1 hour earlier)