Cuvva

Report a problemSubscribe to updates
Powered by
Privacy policy

·

Terms of service
⚠️ We're seeing issues with the app
Resolved·Full outage

Everything is running smoothly again now👌

Sorry for any hassle it might have caused!

Tue, Jun 9, 2020, 10:38 AM
(6 years ago)
·
Affected components
Jun 9, 2020, 10:04 AM
10:10 AM
📱 Cuvva App
Updates

Resolved

Everything is running smoothly again now👌

Sorry for any hassle it might have caused!

Tue, Jun 9, 2020, 10:38 AM

Monitoring

Our engineers have found the problem and it should be fixed, but we're keeping an eye to make sure everything is okay 🔥

Tue, Jun 9, 2020, 10:10 AM(28 minutes earlier)

Investigating

We're seeing some issues in the app, so you won't be able to get a quote or purchase. But our engineers are taking a look, so hopefully it should be fixed soon 🛠️

Tue, Jun 9, 2020, 10:04 AM