We're seeing issues with the app ⚠️
Incident Report for Cuvva
Resolved
We've fixed the earlier issue, and we're sorry for any hassle caused during the brief down-time.
Posted Nov 17, 2020 - 23:14 GMT
Update
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Nov 17, 2020 - 23:09 GMT
Update
We are continuing to investigate this issue.
Posted Nov 17, 2020 - 23:09 GMT
Investigating
Good news! It looks like everything is back up and running, but we're keeping an eye to make sure.

You should now be able to get a new quote from the app.

We’re sorry for any hassle this might have caused. 😊
Posted Nov 17, 2020 - 23:09 GMT
Identified
Our engineers have identified the issue, and are working on a fix for the issue.

Once we know more, we'll keep you updated 👍
Posted Nov 17, 2020 - 22:48 GMT
This incident affected: 📱 Cuvva App and 🎫 Driving licence checks.