Our scheduled maintenance has been completed.
Incident Report for Cuvva
Resolved
This incident has been resolved.
Posted Apr 28, 2020 - 21:04 BST
Update
We've rolled out a fix, but you might still experience issues.

We're sorry for the hassle, we should be back to normal soon.
Posted Apr 28, 2020 - 20:45 BST
Monitoring
We've implemented a fix, and it means you should be able to access your account and get a quote now 👍

We're keeping watch for anything extra that may pop up. Chat to us in the app if you're having issues 💬
Posted Apr 28, 2020 - 20:28 BST
Identified
You won't be able to sign in, get a quote, purchase a policy whilst our engineers complete some system maintenance.

We're sorry for any hassle with this!
Posted Apr 28, 2020 - 17:53 BST
This incident affected: 📱 Cuvva App.