⚠️ Driving licence lookups failing
Incident Report for Cuvva
Resolved
Licence lookups are working again 🎉
Posted Aug 29, 2019 - 23:24 BST
Identified
The MyLicense service is updating their system. Once this is done service should resume as normal.
Posted Aug 29, 2019 - 19:52 BST
Investigating
We are experiencing issues with the DVLA licence system, some licence lookups will fail due to this. We will post updates as we get more information 😥
Posted Aug 29, 2019 - 19:44 BST
This incident affected: 🎫 Driving licence checks.